AccuFund's Licensing and Payment Portal Services Unavailable

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 08:25 MDT

Investigating

AccuFund's Licensing and Payment Portal services are unavailable at this time. Client services are not impacted by this incident, but clients are unable to sync licenses or make payments on invoices payable to AccuFund at this time.
Posted Jul 08, 2026 - 07:52 MDT
This incident affected: AccuFund, Inc. (AccuFund Payment and Licensing Portal).