Some clients are reporting issues with logging in to AccuFund Cloud on the AVD site

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 14:12 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2025 - 10:07 MST

Investigating

Some users are reporting that they're having difficulty logging onto AccuFund Cloud at the AVD site. We are investigating this issue and will provide updates as we solve the problem.

Please contact AccuFund Support if you have any questions regarding this event.
Posted Dec 01, 2025 - 08:35 MST
This incident affected: AccuFund Cloud (AccuFund Cloud AVD).