Adding AccuFund One-Time Secret system to affected components.
Posted Oct 18, 2025 - 08:57 MDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 18, 2025 - 08:00 MDT
Scheduled
Beginning at 8:00 AM MDT on Saturday, October 18th, we will be performing routine maintenance on servers that support the AccuFund Cloud platform (APA site only). During this time, AccuFund Cloud users can expect intermittent interruptions in connectivity or availability. We will communicate in advance wherever possible via the Status Page.
We expect this maintenance to take up to 36 hours to complete.
Please contact AccuFund Support if you have any questions about this maintenance.
Posted Sep 26, 2025 - 14:21 MDT
This scheduled maintenance affected: AccuFund Cloud (AccuFund Cloud APA, Load Balancing APA) and AccuFund, Inc. (AccuFund Academy, AccuFund One-Time Secret, AccuFund SFTP, AccuFund Wiki).