(APA) Expired Certificate

Resolved

This incident has been resolved.
Posted May 18, 2026 - 09:25 MDT

Identified

An updated certificate is being deployed. When the process is complete, affected users must close and re-launch their browser for their browser to retrieve the updated certificate.
Posted May 18, 2026 - 08:43 MDT

Investigating

Users of AccuFund Cloud at the APA site receive browser warnings for an expired site certificate.
Posted May 18, 2026 - 07:12 MDT
This incident affected: AccuFund Cloud (AccuFund Cloud APA).